All OOS regions are updated. Downloads with the new integrity protection mechanism are rejected with HTTP code 400 to prevent silent corruption. The engineering team is working on the implementation of AWS integrity protection. No target version has yet been disclosed.
Posted Feb 06, 2025 - 18:34 CET
Update
Maintenance in progess on all the region.
Posted Feb 05, 2025 - 12:09 CET
Update
We are continuing to work on a fix for this issue.
Posted Feb 03, 2025 - 20:29 CET
Update
We are continuing to work on a fix for this issue.
Posted Feb 03, 2025 - 20:27 CET
Update
We are continuing to work on a fix for this issue.
Posted Feb 03, 2025 - 19:50 CET
Update
We are continuing to work on a fix for this issue.
Posted Feb 03, 2025 - 19:30 CET
Identified
If you don’t use versions of AWS tooling specified below, you’re safe, otherwise:
1. Don't use versions of AWS tooling specified below with OOS 2. If you use them your data have been corrupted when successfully uploading them (answer 200) 3. Double check integrity or reupload files if impacted 4. Workarounds and recommendations provided below DETAILED PROBLEM DESCRIPTION On the 16th of January, 2025, Amazon Web Services (AWS) announced that the AWS SDKs and CLI adopt new default integrity protections when uploading and downloading data from the S3 API. This new integrity protection mechanism is not yet implemented by OOS.
IMPACT : Customer receives a HTTP 200 but data are silently corrupted.
IMPACTED PLATFORMS : All OOS platforms, regardless of their version, are impacted if the following SDKs and aws-cli tool are used by S3 clients.